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Limitation of 

Responsibilities 

 While Prota endeavors to ensure that every new update is tested, Prota 

shall not be held responsible for any losses caused by documentation, 

software, or usage errors. 

In addition to Prota License Agreement Terms, it is the responsibility of 

the user: 

• to check of results generated by documentation and software, 

• make sure that the users of the software and their supervisors 
have adequate technical capabilities, 

• make sure that the software is used correctly following the 
reference manual and documentation. 

 

Intellectual 

Property 

 ProtaStructure is a registered trademark of Prota Yazılım Bilişim ve 
Mühendislik A.Ş., and all intellectual property rights belong to Prota 
Yazılım Bilişim ve Mühendislik A.Ş. Documentation, training, and 
reference manuals, and any program component cannot be copied, 
distributed, and used in violation of the license agreement. 

 

 

Trademarks  ProtaStructure®, ProtaDetails®, ProtaSteel®, and ProtaBIM® are 

registered trademarks of Prota Software Inc. Prota logo is a trademark 

of Prota Software Inc.  
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Introduction 

After the official release of ProtaStructure 2021 (5.0.366) on 7-July-2020, several official updates are 

released with the following schedule: 

Version Release Date 

5.0.366 7-July-2020 (First Customer Shipment) 

Optional weekly beta updates and hotfixes … 

5.0.393 30-July-2020 

Optional weekly beta updates and hotfixes … 

5.0.404 14-Aug-2020 

Optional weekly beta updates and hotfixes … 

5.0.424 1-Sep-2020 

Optional weekly beta updates and hotfixes … 

5.0.454 2-Oct-2020 

Optional weekly beta updates and hotfixes … 

5.1.25 17-Dec-2020 

 

Significant improvements and stability enhancements are made through these updates. Besides these, 

important and useful new features are introduced that will help to increase your productivity. This 

document summarizes the cumulative updates since the first official release of ProtaStructure 2021. 

As a part of our continuous delivery and support commitment, we regularly provide new features and 

improvements with our free updates and new releases to all maintained users. Updating your software 

to the latest version is highly recommended to get the most out of ProtaStructure. 
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ProtaStructure 2021 Installation Steps 

ProtaStructure 2021 updates are deployed dynamically without the need for an installation package. 

Installation packages for the latest release can always be found in the Downloads section at 

www.protasoftware.com or Prota Help Center. 

The latest ProtaSteel 2021 (3.1.6236.3468) is available with ProtaStructure 2021 (5.1.25) installation. 

To get the latest ProtaSteel updates, please download and install the latest ProtaStructure 2021 

(5.1.25) from the download page on the Prota Software web site. 

Installing ProtaStructure 2021 for the first time 

1. Download the latest installer from the Downloads section in www.protasoftware.com or Prota 

Help Center 

2. Make sure that you have the latest Windows updates and graphics card driver. Also, make sure 

that your system configuration meets the minimum requirements listed in 

https://www.protasoftware.com/frequently-asked-questions  

3. Run the installer and follow the installation wizard instructions. Necessary prerequisite runtime 

libraries will be automatically installed by the installer. 

Updating an Existing Version of ProtaStructure 2021 

Alternative 1: Updating by Using the Installer 

If you have the latest installer, you can use it to update the existing version of ProtaStructure 2021. 

1. Before running the installer, remove the previous installations of ProtaStructure2021, 
ProtaSteel2021, and ProtaMeshgen2021. These are listed as separate items in Windows Control 
Panel > Add or Remove Programs 

2. Please make sure you have cleaned the contents of the folders given below. To delete some of 
the directories, you need to make them visible from the menu Control Panel > Folder Options 
> Make hidden files and folders visible regarding safety permissions of your operating system.  

a. C:\Program Files(x86)\Prota\ProtaStructure2021 

b. C:\Users\<UserName>\AppData\Roaming\Prota\ProtaStructure\R5 

c. C:\ProgramData\Prota\ProtaSteel2021 

d. C:\Users\<UserName>\AppData\Local\VirtualStore\ProgramData\Prota\ProtaSteel20
21 

e. C:\ Users \< UserName >\AppData\Local\VirtualStore\Program Files(x86) 
\Prota\ProtaStructure2021 

http://www.protasoftware.com/
http://www.protasoftware.com/
https://www.protasoftware.com/frequently-asked-questions
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3. Make sure that you have the latest Windows updates and graphics card driver. Also, make sure 

that your system configuration meets the minimum requirements listed in 

https://www.protasoftware.com/frequently-asked-questions  

4. Run the installer and follow the installation wizard instructions. Necessary prerequisite runtime 

libraries will be automatically installed by the installer. 

Alternative 2: Updating by Using the ‘Automatic Updates’ 

ProtaStructure will automatically notify you if there is a new ‘Beta’ or ‘Official’ version of ProtaStructure 
2021. You can see the notifications on Welcome Page in the program. Alternatively, you can click on the 
Help > Check Updates… button to see if there are any updates available for your installed version of 
ProtaStructure.  

1. Make sure that you are connected to the internet.  

2. Click on the update notification on the welcome page.  

3. Click on the Download Update button to start downloading the updates. Updated files will be 
replaced automatically and ProtaStructure will be restarted. 

a. Alternatively, click on “Help > Check Updates…”. 

For updates, new license codes are not required, and you do not need to reactivate ProtaStructure 

again. 

Important Note 1: 

ProtaStructure is not supported on the Windows 7 operating system. Windows 7 does not have the 

latest required software libraries to ensure the smooth running of ProtaStructure. During installation 

on Windows 7, unexpected errors may occur, which are beyond our control.  

Microsoft removed support for Windows 7 on 13-January-2015. Extended support ceased on 14 

January 2020. Windows 7 users wanting to use ProtaStructure must upgrade to Windows 10.  

 

Important Note 2: 

You can optionally subscribe to ‘Beta’ updates to get the weekly builds of ProtaStructure. However, 

the beta updates are not official stable releases so they contain untested features and you may 

encounter bugs and errors. It is at your own risk to subscribe to beta updates. 

Beta updates can be subscribed from Settings > View & Save > Update Channel 

If you have subscribed and roll-back to the previous stable release, you must uninstall ProtaStructure 

2021 and reinstall again using the installer for the stable release. Please refer to the ‘Updating an 

Existing Version of ProtaStructure 2021’ step on the previous page. 

  

https://www.protasoftware.com/frequently-asked-questions
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New Features and Enhancements 

Modeling 

Purlin, Girt and Cladding Enhancements 

Load Assignment 

The loading table in purlin, girt, and cladding UI now follows the existing load cases. In the previous 

versions, the UI was showing only a few preset load cases such as G, Q, S, Wx+, Wy+. Please make sure 

that the load cases and combinations are defined before applying any loads on these members, 

otherwise, the load list will be empty. 

 

Purlin Labels 

You can now set the display options for purlin labels using Settings > Label > Purlin Plan Label Settings. 

With the new options, you can either display a label on each purlin frame, display a single label for the 

entire group, or hide the label completely. 

 

Inserting Purlins on Trusses with Only Top or Bottom Chords 

You can delete all diagonals and vertical members of a truss and leave it with only a top chord and 

bottom chord. This technique can be used to model arched members or other configurations of your 

choosing.  
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You can now insert purlins on these kinds of trusses which consist of only top chords or bottom chords. 

  

Frame Member Enhancements 

Frame members are enhanced so that you can control more parameters for a more accurate insertion. 

 

Section Anchors 

Frame sections can be anchored similar to beams or columns, so that, they enlarge only to a specific 

direction when their section is changed. If Middle-Center is selected, the section will enlarge (or shrink) 

in each direction. 
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Local Axis Angle 

Local axis angle can be specified by several methods now. 

Method 1: Direct Input 

Just type in the value of the local axis angle in the Angle field. The section 

will be rotated counter clock-wise with positive values. 

Method 2: Adjust to Member 

You can use the button on the property window to adjust the angle to an 

existing member. Just click the button and pick the member. 

Alternatively, you can select a single frame or multiple frames and select ‘Set Section Angle to Selected 

Member’ on the right-click menu. See the picture below. Beam Members can also be rotated this way. 

 

Method 3: Interactive Rotation 

For the cases where you want to show the angle on the screen dynamically by picking other points or 

by using the dynamic input system (F2), you can select the frame member and use the Rotate command 

on the right-click menu (or contextual ribbon tab) 
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Analytical Offsets 

While inserting the frame members, you may need to use different end offsets when parallel offsets are 

not sufficient. This may be usually the case for vertical and horizontal braces or truss frames.  The offset 

values you enter in these fields will also affect the analysis line of the frame. 

  

Analytical Wire Reference Point 

By this option, you can select the point that the section will be placed with respect to the analytical wire. 

For example, if the Middle Left option is selected, the analytical line will pass through the middle-left 

corner of the section and the section will be placed accordingly. 

 

Physical Offsets 

Out-of-Plane and  In-Plane physical offsets are used to shift the member parallel to the analytical wire. 

Unlike analytical offsets, physical offsets will not affect the analysis wire and should be used for 

constructability purposes. Large values should be avoided. 

 

Extend Columns End Points to Other Members 

You can now extend column member endpoints to align to other beams, frames, and trusses. 

1. Select a single column or multiple columns 

2. Right Click and select “Extend Column to Member” 

3. Alternatively, you can select the same command under the Column Options contextual ribbon 

tab. 

4. Pick the member to be aligned to. It can be a portal beam, frame member, or a truss. 
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Truss Members Snap 

Smart object snapping is extended to include truss sub-members as well. Previously, only truss joints 

were snapped. Now, you can pick any point along with truss sub members. Smart points at 0.25L, 0.33L, 

0.5L, 0.67L, 0.75L can be picked. Also, you can press CTRL and drag your mouse along the member to 

snap to certain increments. 
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Custom Truss Editor Enhancements 

Improvements in Convert to Truss 

Convert to Truss operation now better recognizes the frame member sections and automatically makes 

them default for groups like top chords, bottom chords, diagonals, and verticals. 

 

New Tools in Custom Truss Editor 

 

Create Points Between Two Points creates several desired points between two points. Simply pick two 

points and enter the number of nodes. New nodes will be created at equal spacing. 

Divide Frame divides a selected frame into the desired number of frames. 

Add Extension Point allows you to add new nodes in the direction of two selected existing nodes. 

 

Measure allows you to measure the distance between two points. 
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Stretch command works similar to the usual CAD Stretch command.  

1. Click Stretch on the toolbar. 

2. Select the members and the nodes you want to move with window selection 

3. Specify ΔX and ΔY parameters on the input window. 

  

Reset All Filters 

All visibility and visual interrogation filters can now be reset at once by clicking the ‘Reset All Filters’ 

button on the Active Window Settings and Visual Interrogation dialog. 

 

Batch-Edit of ‘Transfer Member’ Property in Member Tables 

In ProtaStructure, columns and walls can be supported by a slab or a beam. These columns and walls 

will be detected and the analytical model will be created considering this condition. When set as 

‘Transfer Member’, ProtaStructure will not issue any discontinuity warning for these members and will 

utilize rigid links where necessary. ‘Transfer Member’ property can now be set in batch mode for 

multiple columns and walls. 
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Top and Bottom Del-Z Values in Corewalls 

If you assign Del-Z values to corewall panels before merging them, they will now be considered in the 

merged corewall as well. All the panels should have the same DelZ value and their top or bottom edge 

should not be inclined. 

  

  

Enhancements in Brace Insertion Algorithm 

Insertion algorithm for braces is improved so that reported issues in member angles are resolved. 
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Performance and Memory Enhancements  

Significant performance and memory improvements are made. Pick Selection and Window Selection is 

faster now. Memory usage and management of graphics windows are also improved to release the 

memory when required. 

Release Notes in Update Window 

Summary of Release Notes is now displayed on the update window. It will be activated after the 5.1.25 

release. 

 

Rod Sections in Profile Database 

Circular solid steel sections (rods) are now a part of the ‘Built-up Steel’ profile database. 
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Loading 

Snow, Rain, and Roof Live Load Cases 

Snow, Rain, and Roof live load cases can be defined by using ‘Loading Generator’. 

Generally in codes, it is recommended to define different load cases for these loads and they are 

recommended to be included in the loading combinations with different coefficients. Especially these 

definitions are important in steel structures where roof loading is prominent.  

  

By checking these options, you can define individual load cases for  "Roof Live Load (Qr, Lr in ASCE-based 

specifications)", "Snow Load (S)" and/or "Rain Load (R)" instead of "Live Load Case (Q)" to roof level 

slabs and elements (such as roof cladding, purlin, beam.). For example, if you check the Roof and Snow 

Load fields, a different set of combinations (in the form of Qr or S or R) will be generated for each of 

these load cases. Even if you assign loads for all of them, these three load cases will not be automatically 

considered in the same combination simultaneously. However, you are free to consider these at the 

same time by editing any combination. 

 

In some codes (eg Eurocode) these load cases are applied with different 

coefficients (as Qr and S or Qr and R). No codes consider the snow and rain 

loads together. 

If you define a load in the "Live Load (Q)" field together with "Roof Live Load 

(Qr)" for a member at roof level, both of these loads will be applied together. 

Therefore, a load should not be defined in the "Q" field for such elements, 

unless specifically preferred. 
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Load Combination Generation Enhancements 

Loading Generator wizard is revisited and significant improvements are made for Eurocodes, US codes, 

and similar codes. Also, user feedback is reviewed and implemented in the software. For Eurocodes, 

Partial factors for dead and live loads (ɣG and ɣQ ) and combination values for accompanying actions for 

imposed loads and wind loads (ψ0) are exposed to the user for further editing. These values are already 

automatically taken from the selected national annex. 

   

Please read our Design Guide on Loading Generator for more information.  

Enhancements in Wind Load Calculation 

Stability improvements are made and user feedback is implemented in the wind load calculation 

module. Calculations and generated load cases are now tightly coupled to selected wind code. 

  

https://support.protasoftware.com/portal/en/kb/articles/protastructure-design-guide-loading-generator
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Code Support 

Thailand Seismic and Wind Code Support 

Seismic and Wind loads can now be calculated according to DPT Standard 1301/1302-61 and 2012 Wind 

Code. 

 

Better Visibility in Wind Code Selection 

Wind codes now can be explicitly selected on Settings > Codes. In the previous versions, the wind code 

selection was embedded in the wind load module. 
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Analysis 

Analysis Post-Processor Enhancements 

Improved Contour Coloring 

Contour coloring is improved so that the spectrum of calculated values is now distinguished better. 

 

Stability and performance improvements are also made in Diagram and Displacement Scaling, Solid 

View, and Selected Member Display. 

Mesh Enhancements 

Stability and performance improvements are made in the Meshing of Slabs with Column Outlines and 

Transfer Walls.  

Improvements in Shell Wall Group Sum Operations 

Group sum (section cut) operations in meshed rectangular and corewalls are significantly improved. The 

results are now created by the solver and the section cut definitions are exported to various other 

analysis software. 

Automated Target Displacement Calculation for Pushover Analysis 

Target displacement can be determined for static pushover analysis using the methods described in 

FEMA356, Eurocode 8, and Turkish EQ Code. 
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Improvements in Building Assessment Procedures 

Stability and performance improvements are made and user feedback is implemented in building 

assessment procedures. 

Drift Check for Multi-Storey Columns 

Drift checks can now be done for the columns spanning more than one story. Previously these columns 

needed to be split at each story level. 
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Design 

Automated Wall End Zones (Boundary Elements) for Core-walls 

Designing end zones (boundary elements) in shearwalls is a challenging task and different codes 

suggest different approaches. In ProtaStructure, you can automatically layout end zones by using a 

percentage of related wall leg. 

Rectangular Walls 

Rectangular shearwall end-zones are laid-out automatically without the need for ‘Polyline Column 

Editor’. In the building critical height- which is usually Hw/6 - the end zone lengths are automatically 

selected as 0.2Lw, and, 0.1Lw outside critical height. The length of the end-zones can be edited in the 

Column Reinforcement Design > Links section.  

 

Corewalls with Known Shapes 

End zones of the corewalls with known shapes such as E, C, L, T, or H can be laid out automatically 

using the Polyline Column Editor.  The percentage of end zones concerning the wall leg can be 

specified by the user.  
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Corewalls with Irregular Shapes 

For random shapes, full automation is not always possible. But we have developed tools to make it as 

easy as possible for you to insert the end zone rebars. 

Method 1: Inserting End Zone Rebars Manually 

1. Simply right-click on the short edge of a wall leg when a triangular indicator is shown. 

2. Select ‘End Zone Link’ and drag on the screen. 

3. Fine-tune the end zone options on the window and click OK to create the end zone links and 

longitudinal bars. 

  

 

Method 2: Inserting End Zone Bar Automatically 

You can use the ‘Insert All Links w/ End Zones’ button on the ribbon bar to create all ‘End Zone Links’ 

and ‘Horizontal Web Links’ automatically. Currently, this command only inserts the end-zone links and 

horizontal web links, but it will be enhanced to place longitudinal bars and tie-bars as well. 
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Pad Footing 

Pedestal Under Steel Columns 

In ProtaStructure, concrete columns are visually extended into foundation depth by default. This 

extension does not change the analytical model but it affects the detailing of the column. However, 

steel columns are not extended downwards.  

When you insert a pad footing or a pile cap under a steel column, there is a new option to add a pedestal 

underneath the column. The pedestal itself is not designed. 

 

Foundation Settings: Use Top Bars 

The new pad footing design module in ProtaStructure 2021 supports the design of top bars in the 

footing. You can turn on/off the calculation of top bars for all footings using the Settings > Foundation 

> Use Top Bars option. You must update the design of existing pad footings for this setting to take effect. 

Foundation Settings: Minimum Footing Depth Setting 

You can also control the minimum footing depth that will be considered in the design using the Settings 

> Foundation > Min. Pad Base Depth option. You must update the design of existing pad footings for 

this setting to take effect. 
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Stability Enhancements and Design Optimizations 

Several stability enhancements and design optimizations are made and user feedback is implemented 

in the pad footing module. 

Beam Settings Enhancements 

ProtaStructure provides comprehensive design and detailing options for RC beam members. We have 

reorganized the beam settings to avoid confusion and increase usability. 

Reorganization and Improvement in Floor, Rib, and Foundation Beam Settings 

Floor, rib, and foundation beam settings are separated and reorganized. 

 

Use Special Torsion Links 

The ‘Use Special Torsion Links’ option is revisited for better clarity. In the previous version, the usage 

was not intuitive. Special torsion links may be required when there is a big torsional moment on the 

beam.  
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BIM Integration 

IFC Import and Export Enhancements 

IFC Import and export operations are improved based on user feedback. Since IFC content and 

interpretations can vary among structural and architectural software, the problematic cases are 

resolved as different IFC files are received from our users. 

Improvements in ETABS Export 

ETABS export functionality is revised and user feedback is implemented. Following items are supported 

now: 

• Equivalent Static Forces are now exported to Diaphragm Master Joints. 

Important Note: 

ETABS has its method of detecting diaphragm master joint. When exporting to e2k, a separate joint is 

created in diaphragm master coordinates and EQS loads are assigned to it. You will need to assign this 

joint to the diaphragm manually. e2k file format does not allow this operation.  

For RSA loads, you need to perform mode superposition analysis in ETABS to obtain the results. 

Spectrum functions, load cases, stiffness, and mass properties are exported to ETABS by 

ProtaStructure. Pay attention to use the accidental eccentricities. 

• Corewalls are assigned separate PIER definitions in addition to rectangular walls. 

• Section modifiers for shell members are now exported consistently with the ones in 

ProtaStructure. 
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Improvements in SAP2000 Export 

Groups and Section Cut Definitions for rectangular walls and corewalls are now automatically 

communicated to SAP2000 for convenience. 

 

Detailing 

Shearwall Web bar Layout Options for Ductile Detailing 

ProtaStructure now supports different shearwall web bar layout options for ductile detailing. The 

conventional practice is to wrap the horizontal web bar outside end-zone longitudinal bars, which is the 

first option. Second and third options provide better confinement by putting web bars completely in 

the core or crank them into end zones. These kinds of detailing options are suggested by some of the 

seismic codes. 
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Beam Elevation Sorting 

Beam elevation drawing can now be sorted to axis label and story in ProtaDetails. 

 

Reports 

Self-Weights in Beam Load Analysis Checks Report 

Beam self weights are now included in the Beam Load Analysis Report. 

 

  



Page - 29 

 

 

Story Materials in Pre-Analysis Checks Report 

Default material assignments for different stories are now summarized in the pre-analysis checks report. 

 

Imposed Load Reduction Factors in Pre-Analysis Report 

Live load reduction factors are added to the story table in the pre-analysis checks report. 
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ProtaSteel 

Transfer of Sag Rods to ProtaSteel 

Sag-rods that are inserted in ProtaStructure are now transferred to ProtaSteel as well. Sag-rod macro is 

also available in ProtaSteel. 

 

New Multiple Selection Window 

Multiple selection window is re-developed to handle object filtering and grouping. This increases 

usability and reduces the need for the ‘Selection Filter’ command. 
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Hollow Section Base Plate Connection Macro 

You can now insert base plate under CHS, RHS, and SHS hollow profiles. Shear key functionality will 

follow soon. 

 

Zoom Fit to Macros and Other Objects 

You can now zoom fit to macros (and other objects) by hitting ALT+Z on the keyboard and typing in the 

object ID numbers separated by a space character. 
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Manual Connection Macro Command on Right-Click Menu 

Manual connection macro commands are now added to the right-click menu. You can launch the 

‘Manual Macro Wizard’ or create a manual macro using existing settings. 

 

Manual Connection Macro Wizard 

Creating manual connections is much easier now in ProtaSteel. You can launch the “Manual Macro 

Connection Wizard” by selecting the “Manual Macro > Define New Manual Connection” command on 

the right-click menu. You can then follow the steps in the graphical UI to define the manual connections. 

  

A New Manual Connection Placement Type: On Object 

A new manual macro placement type, ‘On Object’ is introduced. This type helps you to create custom 

connections that need to be defined on another object rather than the interaction of multiple profiles. 
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Auto Name Increment for Detail Objects and Sections 

You can now set how the detail object and section names will be auto-incremented. New settings are 

introduced in File > Settings > Project Preferences > Drawing 

 

Viewport Label Settings 

Viewports can be assigned custom labels in the drawing module. You can use [Name] and [Scale] 

keywords to use the view name that the viewport is generated from and the scale information. You can 

reach the Viewport Label parameter by Double-clicking the viewport > Viewport Property Editor > Label 

Settings. 

 

Annotation Grouping for Anchor Bolts 

Unnecessary annotations are prevented by grouping the anchor bolts in connection detail drawings. 
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Shear Stud Insertion by Distance 

Shear studs can be inserted at equal distances or a custom distance pattern. 

  

Performance Improvements in Welded Pipe Connection Macro 

Optimizations are made in welded pipe connection macro. It works faster now. 

Improvements in Connection Design Checks and Reports 

Additional checks are introduced and cross-reference clarifications are added for the checks that are 

absent in one code and available in another. Sketches in the reports are also improved for better clarity. 
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Thank You 

Thank you for choosing the ProtaStructure Suite product family. 

At Prota it is our continual aim to provide you with user-friendly, industry-leading technology for 

building design and documentation  

Should you have any technical support requests or questions, please do not hesitate to contact us at all 

times through globalsupport@protasoftware.com or asiasupport@protasoftware.com  (Asia Pacific) 

Our dedicated online support center together with our responsive technical support team is available 

to help you get the most out of Prota’s technology solutions.  

The Prota Team 

 

mailto:globalsupport@protasoftware.com
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